Student News

Students: During Thanksgiving break, avoid over-eating and macOS Catalina!

Kimberly Butz – November 22, 2019

We continue to receive reports from students, our peers at other schools, and our vendors, that Appleā€™s latest release – macOS 10.15 Catalina – is causing some serious issues. We are writing to remind you that many of the software packages in use on campus right now are not compatible with macOS 10.15 Catalina. Upgrading to Catalina will cause these applications to stop working! We are waiting for our software providers to update their software and/or to let us know what our options are moving forward. Until we have more information from our vendors, please do NOT upgrade your Mac to macOS 10.15 Catalina.

If you have any questions, please contact the ITS Help Desk.