Student News

Calling all Mac users … Defend against Meltdown and Spectre!

Kimberly Butz – January 25, 2018

Earlier this month, you heard from ITS about the serious threat posed to your computers, and our systems and networks, by the Meltdown and Spectre security flaws. Apple has now released updates to macOS High Sierra that mitigate the effects of these two vulnerabilities, and ITS has completed its testing of this release. We are now instructing all users to upgrade their school-owned Macs to macOS High Sierra as soon as possible.

Please look for a recent email from ITS with instructions for upgrading your computer, and contact the Help Desk if you need assistance. Thank you!